Our courses can be viewed in a variety of browsers, but for a smooth and error-free experience, we recommend using IE11, Safari 7, FireFox 27+, or Chrome 33+.

We recommend a minimum video display of 1024 x 768. Additionally, you will need either speakers or headphones in order to hear the audio content of the videos.

To view downloadable course content, you will need Adobe Acrobat Reader, which is free to download here.

Microsoft has ended support for Windows XP and older operating systems. Simplicit E-Learning requires that all Windows users upgrade to Windows 7 Service Pack 1 or higher.

All videos are presented in High Definition.

Your user name is the email address associated with your account. If you can’t recall email address you selected when registering, use the Contact Us Tab on the Menu. We will contact you with the email address / user name.

For security purposes, your password is protected. If you have forgotten your password it can be reset using the functionality on the LOGIN tab on the home page. Click on LOGIN, and Click on “Forget Password”. A temporary password will be sent to the email associated with your account. This is also your user name. Follow the instructions and use the temporary password provided to regain access to your account. Once you have successfully LOGIN the system, go to the Account Settings tab in the left-hand navigation and reset your password.

This site requires the use of cookies to remember you as a user and store your progress. If your browser does not currently have cookies enabled, please enable them. If you need assistance with this, please follow the links below for instructions related to your chosen browser.



CHROME

FIREFOX

SAFARI

INTERNET EXPLORER

This site requires the use of JavaScript for various functions. If your browser does not currently have JavaScript enabled, please enable it or accept any browser requests to enable it. If you need assistance with this, please follow the links below for instructions related to your chosen browser.

CHROME

FIREFOX

SAFARI

INTERNET EXPLORER

There are two versions of the video player this course uses. The version of the player in use will depend on the browser you are using.

MAC
Firefox (any version): Flash
Safari (5+): HTML5
Chrome (any version): HTML5

WINDOWS
Firefox (21+): HTML5
Chrome (any version): HTML5
Internet Explorer (11+): HTML5
Internet Explorer (older): Flash

If you are having difficulty playing the video or you are using one of the browsers indicated above, you can download the latest version of Flash here.

No, the site is not JAWs compatible at this time.